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This exercise is made for those who want to practice with analysing structures with the use of space syntax. 

Two building plans will be analysed and the method on how they are analysed is shown in a step by step 

fashion. In this exercise explanatory text is identified by having a white background while the parts where 

you have to perform steps yourself are identified by having a gray background. 

1. Introduction 

The immediate space around us is the house we live in, the place we go to work, or study and after that the 

grocery store we visit or the place we go to have a walk. Essentially the city we live in. This city has 

developed over time into what it is now and will be. It is structured in such a way that you can access your 

workplace fairly easily, you can get your groceries relatively closely and visit the park. In an optimal world 

this would always be true. The deciding factor in if this is true is space syntax (Hillier and Hanson, 1989). 

Space syntax is essentially a set of rules you need to follow to move between spaces. If you need to go to 

another room chances are that you cannot go there directly. If you move between the cafeteria and your 

workplace you need to cross a corridor. You cannot teleport, you have to obey the space syntax.   

This space syntax has a lot of influence on our daily lives and how we interact with space and others. The 

previously mentioned corridors are crucial in this. These are public places, everyone needs to go through a 

corridor to get from room to room. Corridors connect areas with each other resulting in busier areas and 

thus contact. The way they are designed thus is very important. If they are inefficient or uninspired they will 

lead to bottlenecks and the natural structure will be interrupted. We can analyse the structure of the space 

syntax by treating it as topology (Jiang and Okabe, 2014). This topology should follow scaling law to be as 

efficient as possible (Jiang, 2013). This follows the natural structure of the world. There are far more smaller 

things than larger ones. When you go to a place you will take the highway (big), a lot of people take the 

highway to go to other places than you. When you near your destination you come across less and less 

people because these roads are smaller. 

Urban complexity has been a problem since cities have existed, scientific research has however lagged 

behind as it took a long time before city planning and rebuilding was considered a science. Jane Jacobs 

described their practices as “a foundation of nonsense” (Jacobs, 1961, p. 13). She argued that modern urban 

planning oversimplified the complexity of human lives in their respective communities. She specifically 

opposed large scale urban projects as they did not respect the connections and structures of the communities 

and areas around them as did several others after her. (Jacobs, 1961, Alexander, 2004 and Salingaros, 2014). 

This provides an insight into urban complexity, as one very important factor is that everything is connected 

to everything and therefore new areas should fit in, if they do not, they may be rejected if not properly 

prepared, just like organs in a human transplantation will do. 

This structure of main roads and smaller branches is natural, it is like a tree. You have a lot of tiny roads 

connecting houses with bigger roads which in term connect to highways. This is very important and the 

design of this determines the efficiency. Cities or structures are perceived by mental maps formed in our 

minds. Key elements or the most recognizable landmarks are central in this. We can easily remember the 

big things supported by smaller ones (Lynch, 1960). If you do not follow this scaling law property of nature 



you will create bottlenecks and issues. Within urban city design it is therefore important to keep this in mind. 

This is also the reason why older cities can grow so large, they have evolved naturally over time, depending 

on the then current needs. It fits to the natural use. 

2. Data resource and software requirements 

This exercise uses ArcGIS Pro software to analyse several floorplans of the campus which can be found on 

the walls of the buildings. The floorplans have been obtained by taking a photo of the “utrymmningsplan” 

or evacuation plans on the respective floors. The photo has then been imported into ArcGIS Pro and 

georeferenced to their actual location in Gävle. This data is available HERE. You will also need to calculate 

head/tail breaks (https://en.wikipedia.org/wiki/Head/tail_breaks) and for that an excel calculator is made 

which can be found here: https://github.com/ChrisdeRijke/HeadTailBreaksCalculator. You will need the 

“ExcelHTcalculatorOneColumn.xlsx” file for this analysis. 

3. Digitizing rooms from the floorplan 

In ArcGIS create a new project and add the two images (Karta99_5.png and Karta11_3.png) to your map 

screen. They contain information on how the rooms and offices are organized for the fourth floor of house 

99 and for the second floor of house 11. The first step is to digitize all rooms for both floors, for this create 

two new feature classes. 

Open the Catalog and navigate to the geodatabase which is created when you create your project. Right-

click it and select New > Feature Class. The Create Feature Class screen will open up. Name it appropriately 

(Hus99Plan5 & Hus11Plan3) and make sure the Feature Class Type is set to Polygon. Untick M Values and 

Z Values and leave Add output dataset to current map checked. Click Next and add two new fields: 

Connections with data type: Short integer and Area with data type: Float. Click Next and select SWEREF99 

TM as coordinate system, thereafter click Finish to create the new file. 

Now start digitizing the different rooms for both floorplans. Keep both files 

and floorplans separated as this will be important in the visualization when 

you are finished. To start digitizing, click on Edit > Create. Select one of the 

two files (Hus99Plan5 or Hus11Plan3) and draw polygons around the rooms 

visible on the floorplans (see figure 1). Do this for both floorplans. Don’t 

forget to save the edits when you are done (Edit>Manage Edits>Save)! 

After the rooms have been digitized connectivity data has to be added. How 

many connections (or entrances, or doors) does each room have. For that you 

will have to investigate the floorplan to identify the entrances. It might be a 

good idea to use a symbology that allows you to see through your digitized 

work (perhaps a transparent symbology). To add connectivity to each room go into the attribute table of the 

layer. (Right-click>Attribute table, or CTRL-T, or hold CTRL and double click the layer). In the attribute 

table double-click on the first row (marked in red in figure 2). You are zoomed in to the selected room and 

when you have chosen a transparent symbology or one with a thin line, you should be able to identify the 

number of doors or entrances of the room. You can then fill this number in under the connections attribute 

(double-click on the value under connections, should be <null> if you have not changed it yet). 

 

Figure 2 Double click the marked are to select and go to the selection in the map view 

Figure 1 Digitizing rooms 

https://en.wikipedia.org/wiki/Head/tail_breaks
https://github.com/ChrisdeRijke/HeadTailBreaksCalculator


When you are adding/counting connectivity think about how many connections to other rooms each room 

has. For most rooms this will be relatively straightforward, one door = one connection. However, stairways 

and elevators have more connections. A stairway will have additional connections to a bottom floor and 

(possible) upper floor, while the elevator has connections to all floors it can reach. Additionally, there are 

some parts of the floorplan which do not show a door, while there is actually a passageway, notably the end 

of the hallways connecting building 11 to other buildings – if you are not sure about a connection, it might 

be an idea to have a look in the real world how it looks. 

After you have filled in the connections field, the area field also needs to be calculated, ArcGIS can do that 

for us. If you right-click the area field in the attribute table you have to select Calculate Geometry and fill 

in the appropriate parameters, see figure 3. 

 

Figure 3 Calculate geometry for the area attribute in square meters 

4. Analysing connectivity of the rooms 

After section 3 you should have data available about the connectivity and area of the different rooms around 

campus, this however is not immediately visible in your map yet. This section is going to help you visualize 

the floorplans in different ways to obtain some information about the organization of the different floors 

around the campus, and this allows you to compare the two as well – eventually we should be able to 

determine which floor is “better” in terms of its structure. 

We need to visualize the two floors in a meaningful way. Both floors can be considered as a separate thing, 

thus the visualization must be based on the floor individually. It makes little sense to use the same 

classification for both floors. We also need a classification which makes sense based on the underlying data. 

What is meant by this is that when the connectivity is long-tailed (i.e. a lot of rooms with few connections 

and a few rooms with a lot of connections), the classification used should reflect this. The default 

classification methods in ArcGIS are generally based on gaussian data (i.e. the bell curve), but that does not 

match now, we need to calculate our own classification. 

We want to use head/tail breaks as a classification method, as this is suitable for long-tailed data, which is 

often observed in spatial data. 

Open Excel and copy the attribute table of one of the floorplans to an empty sheet. You can do this by 

selecting all records in the attribute table (If you have nothing selected just click the Switch button, if you 

https://en.wikipedia.org/wiki/Head/tail_breaks


have something selected click the Clear button and then the Switch button, see figure 4) and then click the 

Copy button (Or press Ctrl-Shift-C). Thereafter you can paste the data in an empty excel sheet (right-click > 

Paste or Ctrl-V) 

 

Figure 4 Selecting everything in an attribute table, with nothing selected click Switch (in red) and then click Copy (in green) 

We need to classify the connections with head/tail breaks. For this there is an easy to use excel calculator 

available. Open ExcelHTcalculatorOneColumn.xlsx. Then copy and paste the values of the connectivity 

column you have previously pasted in an empty sheet in column A of the Excel calculator. This should 

prompt the calculator to fill in the classification in the results section. We are going to look at the results 

under Head/tail breaks 2.0 and then specifically the mean values as they are our classbreaks, see figure 5. 

 

Figure 5 Interpreting the head/tail breaks calculator results 

In our example there are 4 class breaks, which means that there are 5 classes in total. Lets symbolize our 

data according to this classification now. Open the symbology of the floorplan layer and select Graduated 

Colors as Primary symbology. Then select the appropriate amount of classes determined by the head/tail 

breaks classification calculator (which would be 5 in the figure 5 example). Then edit the upper values under 

class breaks in the classes tab so that they match with the mean values in the head/tail breaks calculator. 

Note that the final value should be the highest value in your dataset, see figure 6. 

 

Figure 6 Classification of connections according to the head/tail breaks calculator result in figure 5 



You can choose your own colorscheme for the visualization, but a color scheme which seems to work really 

well for long-tailed data classified with the head/tail breaks visualization is the “Spectrum by wavelength-

Fullbright” color scheme (also used in figure 6). This is not available by default when you use the drop-

down menu of the color scheme, you have to tick show all (and perhaps show names to help with searching 

for it) and then it will be available to be picked. Generally the approach with this color scheme is that red 

colors (high temperature) is for the objects which are few and the blue colors (low temperature) is for the 

objects which are many. In this case red for the very well connected rooms (only a few) and blue for the 

rooms with only 1 or two connections (most rooms). 

Create a symbolized classification for both floorplans based on the head/tail breaks classification of the 

connections each room has. 

5. Submission 

To complete the exercise/workshop you have to make a single layout (Insert > New Layout) with two maps, 

one of each of the floorplans, both showing a visualization based on the head/tail breaks classification of 

the floorplans. Additionally your layout should include a paragraph with your interpretation/explanation of 

the results, which floor has a better organization of the rooms and why? Can you explain why certain design 

decisions have been made according to the space syntax analysis? Are there ways to improve them based 

on what you have learned? 

For your interpretation think about what it means for a room to have many (or few) connections. If a room 

is well connected (for example a hallway) many people need to travel through it to reach other rooms, thus 

it is busy. On the other hand, if there is only one connection, the room is relatively private or a one way 

option, i.e. the final destination of someone. 

Finally export your final layout to a pdf for submission on canvas. 

6. Additional analysis 

Additionally the area of the rooms has also been calculated, but not used yet, we can analyse this as well, 

are there many small rooms and only a few big ones or not? Also think about the combination of area and 

connectivity. We can create a new field in the attribute table and then when we divide area by connectivity 

(Calculate Field) we can analyse perhaps which rooms are the least safe in a case of a fire – if there is a 

very big room with only one entrance, there are little escape possibilities (except for separate fire escapes 

ofcourse). If we divide connectivity by area we will identify the rooms which are specifically small for the 

amount of connections they have (like bathrooms or small hallways). You can calculate the head/tail breaks 

as well for the area attribute or for the potentially created area/connections or connections/area attributes 

and create a similar visualization as you have done for the connections. 
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